Home

MIB Views

  1. Up to Table of Contents

Main Menu

This section will introduce you to the MIB Views Main Menu. The Main Menu is divided into 5 primary menus: File, Edit, Tools, View, and Window. The items in each of these menus are described below. Where menu items correspond directly to Toolbar buttons, the icon for those buttons is also shown below.

File Menu

File/session activities.

New Agent...
Opens a new MIB Views window and prompts for agent settings (initialized to defaults) for a new agent connection.
Open Agent...
Opens a saved SNMP Agent Settings file and establishes communication with the agent. If an agent is already configured for the current window, a new window is opened for the new agent.
Save Agent
Saves the current agent configuration to the current file.
Save Agent As...
Saves the current agent configuration to a new file.
Add/Remove MIBs...
file icon Manage the set of loaded MIB files used across all sessions.
Agent Settings...
settings icon Change agent settings for the current session/window.
Export Data...
Saves data from the active tool to a .txt or .csv file.
Exit
Exit the MIB Views application.

Edit Menu

Clipboard operations.

Cut
Delete the selected text from a form entry and place the deleted text into the clipboard.
Copy
Copy the selected text into the clipboard.
Paste
Paste the clipboard contents into the selected form entry.

Tools Menu

Open other SNMP Management Tools and Plugins.

Trap Watch
Monitor incoming notifications (traps and inform requests) in real-time.
Tree View
Switch to Tree View tool to browse the Agent's MIB Tree.
SNMP Query
Switch to the SNMP Query tool to perform manual SNMP requests on one or more variables.
SNMP Walk
Switch to the SNMP Walk tool to perform a get-next walk of a subtree or the entire agent.
Table View
Switch to the Table View to query MIB table data.

View Menu

Configure the MIB Views GUI to show/hide features.

Trap Watch
Show/hide columns in the Trap Watch tool.
Tree View
Show/hide columns in the Tree View tool.
SNMP Query
Show/hide columns in the SNMP Query tool.
SNMP Walk
Show/hide columns in the SNMP Walk tool.
Table View
Show/hide columns in the Table View tool.
Message Log
Show/hide the Message Log panel at the bottom of the main window.
Clear Log
Clear the Message Log.

Window Menu

Show/resize windows and activate open Workspace pages.

New...
Open a new window/session with another SNMP agent.
Close
Close the current window/session.
Maximize
Maximize the current window.
Minimize
Minimize the current window.
# - (page name)
Activate the selected session/tool window.
  1. Up to Table of Contents