MIB Views

  1. Up to Table of Contents


When you first start MIB Views, or when you open a new window, you'll be presented with the Agent Settings dialog. Once you've specified agent settings and successfully contacted the agent, you're ready to interact with the agent using the main MIB Views window, shown below.


Figure - MIB Views GUI

Each main MIB Views window is associated with a particular agent; different main windows can be associated with the same or different agents. The IP address, port and SNMP version (or agent file name) are shown in the title bar. The sysDescr.0 value for the agent (that is, the description of the agent) is shown immediately below the Toolbar, so you can see at a glance which window is associated with which agent.

Most tools designed to interact with a particular agent are available under the named tabs in the middle section of the GUI. These include the Tree View, SNMP Query, SNMP Walk, and Table View, tools. Other tools that are more general or do not require interacting with a specific agent, such as the Trap Watch tool, are available under the Tools menu.

At the top of the GUI is the main Toolbar, where you can control or filter data in the active (visible) tool. Each tab has its own instance of the main toolbar, and may have an additional toolbar specific to the SNMP tool.

At the bottom of the GUI is a Status Bar that can keep you apprised of progress when the active tool is interacting with the agent.

Immediately above the Status Bar, and below the tools, is the Message Log. This panel provides a running hex dump of SNMP packets sent to and received from the agent. You can use the "grab bar" at the top of the log window to resize the window relative to the tools. The log can be hidden from the View menu.

Tip: Most lists and tables in the MIB Views GUI can be sorted by clicking on the column header, and columns can be resized or temporarily reordered by dragging the separator between columns. Columns can be shown or hidden by right-clicking on the column header or from the View menu.
  1. Up to Table of Contents